好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

通达信多合一选股/预警指标 附图 源码

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2017-08-06 22:15:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:0 Bytes
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

通达信多合一选股/预警指标 附图 源码介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:通达信多合一选股/预警指标 附图 源码

多款不错的选股预警指标综合为一个附图,源码放松

参数设置
参数 最小 最大 缺省
NNN 0 200 50
N1 1 1000 104
N2 1 100 99
=================================================

{收复江山}
{思路就是股价收复昨日大阴线或者长上影线时预警。
该公式导入通达信即可在盘中选股。其中有两个参数N1和N2可自己设置,N1代表昨天上影线或者大阴线的长度,默认4个点的长度;N2代表当前股价收复昨天最高价多少的时候预警,默认当股价距离昨天最高价1个点的时候预警进行观察。
预警后何时买入:
预警后观察该股是否放量,在该股马上要冲过昨日最高点的时候全仓买进等板。要求昨日的K线位置不要处在连续大涨之后,最好刚刚跳空突破的时候。}
A:=REF(H,1)>=REF(C,1)*N1/100;
B:=C>=REF(H,1)*N2/100 AND DYNAINFO(8)>0;
R:=C=H;
收复江山:R AND A AND B,COLOR4D4DFF;
STICKLINE(收复江山,0.5,0.1,1,0),COLOR4D4DFF;
DRAWTEXT(收复江山>0,0.05,'收复江山'),COLOR00FFFF;
{宝宝涨停}
ST:=IF(NAMELIKE('S'),0,1);
XXG:=IF(NAMELIKE('*'),0,1);
TP:=DYNAINFO(4)>0;
XIAO:=FINANCE(7)<=6000000000;
YZ:=C/REF(C,1)>1.0975 AND H=O;
LTGB:=ST AND XXG AND TP AND XIAO AND NOT(YZ);
XA_1:=IF(CLOSE>OPEN AND HIGH>REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);
XA_2:=IF(CLOSE>OPEN AND HIGH<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);
XA_3:=IF(CLOSE>OPEN AND HIGH=REF(CLOSE,1),0,0);
XA_4:=IF(CLOSE<OPEN AND HIGH>REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);
XA_5:=IF(CLOSE<OPEN AND HIGH<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);
XA_6:=IF(CLOSE<OPEN AND HIGH=REF(CLOSE,1),0,0);
XA_7:=XA_1+XA_2+XA_3+XA_4+XA_5+XA_6;
XA_8:=MA(XA_7,9);
XA_9:=MA(XA_7,5);
XA_10:=MA(XA_7,3);
XA_11:=IF(CLOSE>OPEN AND LOW>REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);
XA_12:=IF(CLOSE>OPEN AND LOW<REF(CLOSE,1),-(ATAN(REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);
XA_13:=IF(CLOSE>OPEN AND LOW=REF(CLOSE,1),0,0);
XA_14:=IF(CLOSE<OPEN AND LOW>REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);
XA_15:=IF(CLOSE<OPEN AND LOW<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);
XA_16:=IF(CLOSE<OPEN AND LOW=REF(CLOSE,1),0,0);
XA_17:=XA_11+XA_12+XA_13+XA_14+XA_15+XA_16;
XA_18:=MA(XA_17,9);
XA_19:=MA(XA_17,5);
XA_20:=MA(XA_17,3);
XA_21:=ATAN(XA_8/0.09);
XA_22:=ATAN(XA_9/0.05);
XA_23:=ATAN(XA_10/0.03);
XA_24:=ATAN((-XA_18)/0.09);
XA_25:=ATAN((-XA_19)/0.05);
XA_26:=ATAN((-XA_20)/0.03);
XA_27:=C/REF(C,1)>1.028 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
XG1:=FILTER(XA_27,28);
XGG:=(XA_23+XA_22+XA_21)/3/6.28*360;
XG2:=XGG-REF(XGG,1)>0;
AA05:=EMA(C,5);
HJ:=ATAN((HIGH-REF(HIGH,1))/REF(HIGH,1)/0.1)/6.28*360;
LJ:=ATAN((LOW-REF(LOW,1))/REF(LOW,1)/0.1)/6.28*360;
CJ:=ATAN((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)/0.1)/6.28*360;
OJ:=ATAN((OPEN-REF(OPEN,1))/REF(OPEN,1)/0.1)/6.28*360;
AM:=MIN(MIN(MIN(CJ,OJ),HJ),LJ);
BM:=MAX(MAX(MAX(CJ,OJ),HJ),LJ);
A11:=MIN(CJ,OJ);
B11:=MAX(CJ,OJ);
T:=IF(B11>0 AND A11>0,B11,0);
D:=IF(B11<0 AND A11<0,A11,0);
J1:=IF(B11>0 AND A11<0,B11,0);
J2:=IF(B11>0 AND A11<0,A11,0);
TM:=MA(T+J1,1);
DM:=MA(D+J2,1);
JX:=TM+DM;
T1:=FINDHIGH(BM,1,3,1);
T2:=FINDHIGH(BM,1,3,2);
Y:=BARSCOUNT(T1)<BARSCOUNT(T2);
W1:=IF(Y,T1,0);
W2:=IF(Y,T2,0);
N1:=W1-W2;
XG66:=MA(REF(T1+N1,1),5);
XG6:=XG66-REF(XG66,1)>0;
WURI:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
AA30:=EMA(C,30);
HDBB:=HIGH-REF(HIGH,1);
BBR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),15);
LDBB:=REF(LOW,1)-LOW;
BBP:=EXPMEMA(IF(HDBB>0&&HDBB>LDBB,HDBB,0),15);
XG77:=BBP*100/BBR;
XG7:=XG77-REF(XG77,1)>0;
SANRI:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(WURI,0),3)>=1 AND SANRI>REF(SANRI,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>2 AND REF(C,1)<AA30;
XG5:=FILTER(MR,10);
宝宝涨停:XG1 AND XG2 AND XGG>30 AND LTGB AND XG6 AND XG7,COLORFF1CAE;

{乾坤骑牛}
TJ1:=O=L AND C>O AND O/REF(C,1)<0.95;
TJ2:=MA(C,5)<MA(C,10) AND L<MA(C,5) AND H/O>1.1;
TJ3:=H/C>1.07 AND V>REF(HHV(V,800),1);
TJ4:=TJ1 AND TJ2 AND TJ3;
TJ5:=REF(TJ4,1) AND C>REF(C,1) AND NOT(O=C AND C/REF(C,1)>1.098);
TJ6:=REF(C,1)>REF(O,1) AND REF(H,1)/REF(C,1)>1.01;
TJ7:=REF(C,1)/REF(C,2)>0.94 AND O<REF(O,1) AND C/REF(C,1)>1.005;
TJ8:=REF(C,1)/REF(C,5)<1.2 AND REF(O,1)/REF(L,1)<1.0045 AND REF(C,1)/REF(O,1)>1.015;
TJ9:=TJ6 AND TJ7 AND TJ8;
TJ10:=REF(C,1)>REF(C,2) AND C/REF(C,1)<1.03 AND REF(C,1)/REF(O,1)>1.05;
TJ11:=O<(REF(C,1)+REF(O,1))/2 AND C>O AND C>REF(C,1);
TJ12:=TJ10 AND TJ11;
TJ13:=REF(COUNT(TJ12,2)>0,1) AND C/REF(C,1)>1.05 AND O<MA(C,5);
TJ14:=O<MA(C,10) AND C>MA(C,5) AND C>MA(C,10) AND MA(C,5)/MA(C,10)<0.98;
TJ15:=TJ13 AND TJ14;
乾坤骑牛:TJ5 OR TJ9 OR TJ15,COLORFF1CAE;
{WR钝化}
WR钝化:EVERY(RSI.RSI2<25,3) AND EVERY(WR>80,5),COLOR007FFF;
{买点0}
N:=20;NM1:=7;NM2:=69;
AW:=IF((DATE<=9990314),1,0);
M3:=EMA(CLOSE,3);M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);M62:=MA(M8,55);
A1:=EMA(M13,62);M81:=EMA(M62,81);
M144:=EMA(A1,144);M250:=EMA(A1,250);
A2:=(CLOSE+HIGH+LOW)/(3);
A3:=(EMA(A2,10))*(A);
A4:=(REF(A3,1))*(A);
A5:=((REF(HIGH,1)+REF(LOW,1))/(2))*(AW);
A6:=MA(CLOSE,N)+((2)*(STD(CLOSE,N)))*(AW);
A7:=REF(CLOSE,1);
A8:=((SMA(MAX(CLOSE-A7,0),NM1,1))/(SMA(ABS(CLOSE-A7),NM1,1)))*(100);
A9:=CROSS(NM2,A8);
A10:=(FILTER(A9,4))*(A);
BB:=((2)*(CLOSE)+HIGH+LOW)/(4);
BC:=LLV(LOW,34);
BD:=HHV(HIGH,34);
BE:=(EMA(((BB-A1)/(A5-A1))*(100),7))*(A);
BF:=(EMA((0.667)*(REF(BE,1))+(0.333)*(BE),5))*(A);
BMM:=(MA(CLOSE,80)-(MA(CLOSE,10))/(3))*(A);
MA1:=MA(C,5);MA2:=MA(C,10);
MA3:=MA(C,30);V1:=CROSS(MA1,MA2),;
V2:=MA3>REF(MA3,1); XG:=V1 AND V2 AND CROSS(C,MA(C,30));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);DMM:=SMA(K,3,1);J:=3*K-2*DMM;AA:=CROSS(K,DMM);
一字板:=NOT(C>=REF(C,1)*1.097 AND C=O AND H=L);
停牌:=DYNAINFO(4)>0;
XGGM:=一字板 AND 停牌;
涨停:(CLOSE>(REF(CLOSE,1))*(1.08)) AND (CLOSE<(MA(CLOSE,13))*(1.3)) AND XG AND AA AND 一字板,LINETHICK2,COLOR0000FF;


{抄底买入}
庄筹估算:=EMA(WINNER(C)*70,5);
散筹估算:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5);
CCC:=FILTER( (CROSS(5,庄筹估算) AND 散筹估算<20 )*60,10 );
抄底买入:CCC,COLORYELLOW,COLORBLUE;
{趋势顶底}
AK:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
BK:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
DKK:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
短期线:=BK+100;
中期线:=DKK+100;
趋势顶底:中期线-短期线>NNN,COLOR7FFF00 ;

{溪钰残殇抄底}
XAZ_1:=MA(KDJ.K#MONTH(9,3,3),21);
XAZ_2:=MA(KDJ.D#MONTH(9,3,3),21);
XAZ_3:=MA(KDJ.J#MONTH(9,3,3),21);
XAZ_4:=MA(KDJ.K#WEEK(9,3,3),5);
XAZ_5:=MA(KDJ.D#WEEK(9,3,3),5);
XAZ_6:=MA(KDJ.J#WEEK(9,3,3),5);
XAZ_7:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
XAZ_8:=SMA(XAZ_7,3,1);
XAZ_9:=SMA(XAZ_8,3,1);
XAZ_10:=3*XAZ_8-2*XAZ_9;
溪钰残殇抄底:XAZ_3>REF(XAZ_3,1) AND XAZ_6>REF(XAZ_6,1) AND XAZ_10>REF(XAZ_10,1) AND XAZ_10<40 COLORFFCC00;

{涨停捉妖}
XAX_1:=EMA(EMA(EMA(HIGH,13),13),13);
XAX_2:=EMA(EMA(EMA(LOW,13),13),13);
XAX_3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XAX_4:=XAX_3>9.85 AND HIGH<XAX_1*1.25;
涨停捉妖:FILTER(XAX_4,5);


{抓妖幅图}

DIFQ:=EMA(CLOSE,12) - EMA(CLOSE,27);
DEAQ:=EMA(DIFQ,9);
MACDQ:=2*(DIFQ-DEAQ);
CCI线:=CCI(84);
分割线:=100.00;
妖股启动:=CROSS(CCI线,分割线) AND MACDQ>0 AND MACDQ>=REF(MACDQ,1) AND REF(MACDQ,1)<REF(MACDQ,2) AND C>=REF(C,1)*1.05;
STICKLINE(妖股启动,1,4,2,0),COLORYELLOW;
{DRAWTEXT(妖股启动,3.5,'妖股启动'),COLORMAGENTA;}

月DIFQ:="MACD.DIF#MONTH";
月DEAQ:="MACD.DEA#MONTH";
周DIFQ:="MACD.DIF#WEEK";
周DEAQ:="MACD.DEA#WEEK";
日DIFQ:="MACD.DIF";
日DEAQ:="MACD.DEA";
日金叉:=CROSS(日DIFQ,日DEAQ);
周金叉:=CROSS(周DIFQ,周DEAQ);
月金叉:=CROSS(月DIFQ,月DEAQ);
金叉共振:=IF(CROSS(周DIFQ,周DEAQ),MACDQ,0) AND C>REF(C,1)*1.078;
共振:IF((日DIFQ>日DEAQ AND 周DIFQ>周DEAQ AND 月金叉) OR ( 周DIFQ>周DEAQ AND 月DIFQ>月DEAQ AND 日金叉)
OR (月DIFQ>月DEAQ AND 日DIFQ>日DEAQ AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACDQ+0.2,0) AND C>REF(C,1)*1.078;
STICKLINE(共振,1,3,2,0),COLORRED;
STICKLINE(金叉共振,0,2,3,0),COLORCC3299;
{DRAWTEXT(共振,2.5,'何氏抓妖'),COLORYELLOW;}
{时间}
QN1:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y1:=STRCAT(CON2STR(MONTH,0),' 月 ');
QR:=STRCAT(CON2STR(DAY,0),' 日 ');
SJ:=STRCAT(STRCAT(QN1,Y1), QR);
DRAWTEXT_FIX(C>0,0.88,0,0,SJ),COLORYELLOW;

{七号}
EE:=MACDQ-REF(MACDQ,1)>0.05 AND COUNT(C/REF(C,1)>1.09,16)<2 AND C=HHV(H,60) AND
C/REF(C,1)>1.07 AND NOT(H=L) AND COUNT(C>O,6)<=4 AND C/REF(C,9)<1.2;
STICKLINE(EE AND C/REF(C,1)>1.05,1,2,4,0),COLORDB7093;
{DRAWTEXT(EE AND C/REF(C,1)>1.05,1.5,'打板启动'),COLORRED;}
VOLUME:=VOL;
QMA1:=MA(VOLUME,5);
启动:= (QMA1+QMA1)>VOLUME;
买入:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND CLOSE>=HHV(HIGH,10)
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND C>O;
选股:=(C>REF(HHV(H,3),1) AND (C-REF(C,1))/REF(C,1)>0.07) AND 启动 AND 买入;
STICKLINE(选股 AND C/REF(C,1)>1.05,0,1,5,0),COLORYELLOW;
{DRAWTEXT(选股,0.5,'蹬蹬启动'),COLORMAGENTA;};


通达信多合一选股/预警指标 附图 源码


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
通达信多合一选股/预警指标 附图 源码下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!