您现在的位置:好股网 >> 股票资讯 >> 炒股技巧
股票资讯分类导航
股票入门 股票知识 炒股经验 股市实战
精品股票资讯
更多>>
本文好评率100%

可以媲美手划线的缠论中枢 通达信公式

出处:本站整理时间:2020-02-17 08:53:00人气:
Tags:

看到一些缠论指标的帖子,以缠论股票池(cl.dll)和分笔分段(fbfd试用.dll,zslx试用.dll)为基础的为多。在试用过之后,发现,这两个缠论的分笔基本可以用,但是分段和中枢 离实用 还有距离。

先后出现过小散大师带缠论股票池的和谐版、单独包装的缠论股票池。本人下载使用后有几点认识,与大家讨论。
1 缠论股票池开发者的指标开发水平很高,缠论主图指标非常漂亮,缠论主图划线设计巧妙。但是,
2 缠论理论分析靠谱,选股指标与缠论相差甚远;
3 MACD指标是分析背驰的重要辅助,随带的智能MACD在背驰分析上存明显偏差。

余以为,与人工手动的精确走势类型分析比,计算机自动分析确实难以做到。不过,可以按以下思路简化:
1 以周K线的笔中枢为依据,点击出日线级别的走势类型;
2 找出日线级别趋势下行走势,在日K线线段向下离开第二以上中枢后,找MACD底背;
3 在第二步找出的背驰段,找出30分钟趋势下行走势,在30分钟K线线段向下离开第二个以上30分钟中枢后,找MACD底倍;
4 在第三步找出的背驰段,找出1分钟级别的趋势上行走势,也就是5分钟K线上的5浪上升;
5 待1分钟级别的趋势上行结束、随后出现的1分钟级别盘整下行,也就是5分钟K线上的三浪回调;
6 第五步出现的1分钟级别盘整下行结束,不破前低,即为日线级别的①买;
7 若出现第六步的情况,则至少出现一个30分钟级别的上行走势类型(盘上或趋势上行),待这个30分钟上行走势完成,
随后出现的30分钟下行走势完成时不创新低,即是日线级别的②买;
8 若出现第七步的情况,则随后必然出现一个30分钟级别的上行(趋势或盘整)走势,这样,第七步开始的三个30分钟级别的
走势类型,形成新的日线中枢。在出现30分钟级别走势(日K线的5浪上涨线段)向上离开这个新的日线中枢后,走势完成后,
30分钟的盘整下行走势(日线3浪调整)完成,不跌回到日线级别的中枢,即是日线级别的③买。

卖出的情况正好相反,以周线级别的笔中枢为依据,点击出趋势上行走势,找日线底背驰线段,随后根据30分钟走势类型找出
①卖②卖和③卖。


 


要点说明:
1 融合了cl.dll和bfd.dll两个分笔划分的优点

{缠论分笔分段XFBFD.DLL,绑定TDXDLL1}
XD:=TDXDLL1(1,H,L,DATE);
BG:=TDXDLL1(2,H,L,DATE);{输出笔高低}
BD:=TDXDLL1(3,H,L,DATE);{输出笔高}

ZG:=TDXDLL1(4,H,L,DATE);
ZD:=TDXDLL1(5,H,L,DATE);
ZSKS:=TDXDLL1(6,H,L,DATE);
ZSJS:=TDXDLL1(7,H,L,DATE);

FBI:=TDXDLL1(18,H,L,DATE) NODRAW; {输出笔}

{笔}
XBGD:=IF(FBI=1,BG,IF(FBI=-1,BD,0));
XBI:=TDXDLL1(19,XBGD,L,1),NODRAW;


{缠论CL.DLL,绑定TDXDLL3}
KX:=TDXDLL3(1,H,L,C);{解决包含K线的问题};
BI:=TDXDLL3(4,H,L,C) NODRAW;{BI类型}
KXG:=TDXDLL3(2,H,L,C);{高点}
KXD:=TDXDLL3(3,H,L,C);{低点}

{综合二者优化笔}
SHOULDHAVEBI:=MIN(233,COUNT(C!=0,-1)),NODRAW;
SHOULDHAVEDUAN:=MIN(288,COUNT(C!=0,-1)),NODRAW;

NEXTUBI:=REFX(BARSNEXT(BI=1 OR FBI=1),1)+1,NODRAW;
NEXTDBI:=REFX(BARSNEXT(BI=-1 OR FBI=-1),1)+1,NODRAW;
GBI1:=IF(FBI=1 OR FBI=-1,FBI,IF(BI=1 OR BI=-1,BI,0)) NODRAW;
LGBI2:=IF(COUNT(GBI1!=0,SHOULDHAVEBI)<1,-1,BARSLAST(GBI1)),NODRAW;
LGBI1:=IF(LGBI2=0 AND COUNT(GBI1!=0,SHOULDHAVEBI)>1,REF(LGBI2,1)+1,LGBI2),NODRAW;
UBCANCEL1:=NEXTUBI<NEXTDBI AND HHV(H,4)<REFX(HHV(H,4),NEXTUBI),NODRAW;
UBCANCEL2:=NEXTUBI>NEXTDBI AND (NEXTUBI-NEXTDBI)<3
AND REFX(NOT((COUNT(L>1.035*REF(H,1),LGBI1)>0 OR COUNT(L>1.01*REF(H,1),LGBI1)>1) AND REF(L,LGBI1)<0.8*H),NEXTUBI),NODRAW;
UBCANCEL3:=REF(GBI1,LGBI1)=1 AND REF(UBCANCEL1 OR UBCANCEL2,LGBI1)=0 AND LGBI1>0,NODRAW;
UBCANCEL4:=REF(GBI1,LGBI1)=-1 AND NEXTDBI<2,NODRAW;

DBCANCEL1:=NEXTUBI>NEXTDBI AND LLV(L,4)>REFX(LLV(L,4),NEXTDBI),NODRAW;
DBCANCEL2:=NEXTUBI<NEXTDBI AND (NEXTDBI-NEXTUBI)<3
AND REFX(NOT((COUNT(REF(L,1)>1.035*H,LGBI1)>0 OR COUNT(REF(L,1)>1.01*H,LGBI1)>1) AND REF(H,LGBI1)>1.2*L),NEXTDBI),NODRAW;
DBCANCEL3:=REF(GBI1,LGBI1)=-1 AND REF(DBCANCEL1 OR DBCANCEL2,LGBI1)=0 AND LGBI1>0,NODRAW;
DBCANCEL4:=REF(GBI1,LGBI1)=1 AND REF(UBCANCEL1 OR UBCANCEL2,LGBI1),NODRAW;
GBI:=IF(GBI1=1 AND (UBCANCEL1 OR UBCANCEL2 OR UBCANCEL3 OR UBCANCEL4),0,
IF(GBI1=-1 AND (DBCANCEL1 OR DBCANCEL2 OR DBCANCEL3 OR DBCANCEL4),0,GBI1)) NODRAW;
LGBI3:=IF(COUNT(GBI!=0,SHOULDHAVEBI)<1,-1,BARSLAST(GBI));
LGBI:=IF(LGBI3=0 AND COUNT(GBI!=0,SHOULDHAVEBI)>1,REF(LGBI3,1)+1,LGBI3),NODRAW;{上一笔的距离}
GBIH:=HHV(H,MIN(5,LGBI));
GBIL:=LLV(L,MIN(5,LGBI));
DRAWLINE(GBI=1,GBIH,GBI=-1,GBIL,0),COLORLIGREEN;
DRAWLINE(GBI=-1,GBIL,GBI=1,GBIH,0),COLORLIGREEN;

2 在优化笔gbi的基础上,依据缠论中枢定义,制定了两类共八种笔中枢的点击规则,依据规则画中枢。结果基本可用。
不足之处是,限于指标编写语言和作者水平的限制,没有完全解决笔包含的问题。

具体的请看图吧。


 

可以媲美手划线的缠论中枢 通达信公式

可以媲美手划线的缠论中枢 通达信公式

可以媲美手划线的缠论中枢 通达信公式

可以媲美手划线的缠论中枢 通达信公式

可以媲美手划线的缠论中枢 通达信公式

可以媲美手划线的缠论中枢 通达信公式

指标公式下载: clWithDll.rar

用到的DLL,放在T0002目录下的dlls目录: CL缠论dlls.rar

分笔分段的DLL需要适配自己的机器才能用,如何获取自己的机器码并替换原文件中的机器码,请自己在本论坛找。
替换机器吗的工具: DLL机器码修改.rar
 
替换机器码需要一个二机制(十六进制)的编辑器,由于文件大无法上传,可以自己网上下载一个。

上面的图一式两份,黄色的划线为无DLL版本,为了适应交易时间无法装载DLL的环境,也避免DLL的不稳定。

对我有用(13)对我没用(0)