好股票网每日提供最新股票软件下载,如果您觉得不错,麻烦推荐给您的好友,谢谢!
您现在的位置:好股票网 >> 股票公式 >> 通达信公式

黄金线阳盖阴主图指标 源码 通达信

[下载地址]

好股票网经过测试可运行,该软件通过多款专业杀毒软件扫描

  • 360通过
  • 金山通过
  • 瑞星通过
  • 江民通过
  • 卡巴通过
  • 诺顿通过
  • 运行平台:Win7/Vista/WinXP/Win2003/
  • 公式语言:简体中文
  • 更新时间:2018-09-14 09:58:00
  • 公式评级:
  • 公式类型:通达信公式
  • 授权方式:共享版
  • 公式大小:5.00 KB
  • 解压密码:goodgupiao
  • 下载统计:
  • 相关Tags:
已有次下载
推 荐0
不推荐0

黄金线阳盖阴主图指标 源码 通达信介绍

好股票软件下载网(www.goodgupiao.com)提示:您正在下载的是:黄金线阳盖阴主图指标 源码 通达信

公式描述: 0=长阳,1=将军柱,2=次黄金,3=黄金,4=标准黄金
参数数量: 6
参数1: 基柱是倍量, 最小: 0, 最大: 1, 缺省: 1
参数2: 基柱类型, 最小: 0, 最大: 4, 缺省: 1
参数3: 显示板块, 最小: 0, 最大: 1, 缺省: 1
参数4: 回踩误差千分之, 最小: 0, 最大: 20, 缺省: 5
参数5: 显示黄金线, 最小: 0, 最大: 1, 缺省: 1
参数6: 回踩类型, 最小: 0, 最大: 4, 缺省: 0

基柱是倍量: 1=倍量,0=小倍量;
基柱类型: 0=长阳,1=将军柱,2=次黄金柱,3=黄金柱,4=标准黄金柱;
显示板块: 0=不显示,1=显示;
回踩误差千分之: 阳盖阴附近回踩点与黄金线的距离误差千分比;

DRAWTEXT_FIX(显示板块 AND ISLASTBAR,0,0,0,HYBLOCK);
DRAWTEXT_FIX(显示板块 AND ISLASTBAR,0.05,0,0,DYBLOCK);
DRAWTEXT_FIX(显示板块 AND ISLASTBAR,0.1,0,0,GNBLOCK);
STICKLINE(REF(LOW,1)>HIGH,HIGH,REF(LOW,1),5,0),COLORGRAY;
STICKLINE(REF(HIGH,1)<LOW,LOW,REF(HIGH,1),5,0),COLORGRAY;
C_:CONST(CLOSE),POINTDOT,COLORLIRED;
X_1:=MA(CLOSE,5);
MA5角度:ATAN((X_1/REF(X_1,1)-1)*100)*180/3.1416,NODRAW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
X_2:=REF(CLOSE,1);
X_3:=IF(CLOSE>=1,10000,100000);
X_4:=1.1*X_2-49/X_3;
X_5:=1.05*X_2-49/X_3;
X_6:=0.9*X_2+51/X_3;
X_7:=0.95*X_2+51/X_3;
X_8:=NAMELIKE(1) OR NAMELIKE(2);
X_9:=IF(X_8,CLOSE>=X_5,CLOSE>=X_4);
X_10:=IF(X_8,CLOSE<=X_7,CLOSE<=X_6);
X_11:=IF(X_8,HIGH>=X_5,HIGH>=X_4);
X_12:=IF(X_8,LOW<=X_7,LOW<=X_6);
STICKLINE(X_11,HIGH,MAX(CLOSE,OPEN),0,0),COLORMAGENTA;
STICKLINE(X_12,LOW,MIN(CLOSE,OPEN),0,0),COLORLICYAN;
X_13:=CLOSE>OPEN AND (CLOSE>=X_5 OR CLOSE>1.05*OPEN-51/X_3) OR (CLOSE>1000 AND CLOSE>X_2*1.024);
STICKLINE(X_13,OPEN,CLOSE,1,0),COLOR0000BB;
X_14:=CLOSE<OPEN AND (CLOSE<=X_7 OR CLOSE<0.95*OPEN+49/X_3) OR (CLOSE>1000 AND CLOSE<X_2*0.976);
STICKLINE(X_14,OPEN,CLOSE,1,0),COLORLIGREEN;
STICKLINE(X_9,OPEN,CLOSE,1,0),COLORMAGENTA;
STICKLINE(X_10,OPEN,CLOSE,1,0),COLORLICYAN;
X_15:=CLOSE<OPEN AND CLOSE>REF(CLOSE,1);
STICKLINE(X_15,OPEN,CLOSE,0,0),COLORRED;
X_16:=CLOSE>OPEN AND CLOSE<REF(CLOSE,1);
STICKLINE(X_16,OPEN,CLOSE,0,0),COLORGREEN;
X_17:=PERIOD=5 AND NAMELIKE(3) AND (ABS(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.025 OR ABS(CLOSE-OPEN)>=60);
STICKLINE(X_17,(HIGH+LOW)/2,(HIGH+LOW)/2,2,0),COLORYELLOW;
X_18:=MIN(CLOSE,OPEN);
X_19:=基柱类型;
X_20:=LLV(CLOSE,3)>=REF(X_18,3);
X_21:=IF(基柱是倍量=1,1.8,1.1);
X_22:=10;
X_23:=FILTER(BACKSET(FILTER(REF(VOL,X_22)=HHV(VOL,2*X_22+1),X_22),X_22+1),X_22);
X_24:=VOL>=REF(VOL,1)*X_21 OR X_23;
X_25:=CLOSE/REF(CLOSE,1)>1 OR CLOSE/OPEN>1;
X_26:=REF(X_25,3) AND X_20;
X_27:=CLOSE>REF(CLOSE,1);
X_28:=CLOSE>REF(MAX(CLOSE,OPEN),1) AND X_25;
X_29:=X_24 AND X_28;
X_30:=REF(X_29,3) AND X_20;
X_31:=MA(CLOSE,3)>=REF(CLOSE,3) AND CLOSE>=REF(CLOSE,3);
X_32:=MA(VOL,3)<=REF(VOL,3)*1.03;
X_33:=X_30 AND X_31 AND X_32;
X_34:=HHV(VOL,3)<=REF(VOL,3)*1.03;
X_35:=LLV(CLOSE,3)>=REF(CLOSE,3);
X_36:=X_33 AND X_35 AND X_34;
X_37:=COUNT(X_27,3)=3;
X_38:=COUNT(VOL<REF(VOL,1),3)=3;
X_39:=X_36 AND X_37 AND X_38;
基柱:IF(X_19=1,X_30,IF(X_19=2,X_33,IF(X_19=3,X_36,IF(X_19=4,X_39,X_26)))),NODRAW;
X_40:=BARSLAST(FILTER(基柱,3));
X_41:=REF(LOW,X_40+3);
X_42:=LLV(X_18,X_40)>=X_41 AND X_41=REF(X_41,1);
底线:IF(X_42,X_41,DRAWNULL),COLORYELLOW;
STICKLINE(基柱,X_41,X_41,25,0),COLORYELLOW;
X_43:=LLV(LOW,X_40);
X_44:=LLV(X_18,X_40);
基柱O:REF(OPEN,X_40+3),NODRAW;
X_45:=REF(LLV(LOW,3),X_40);
X_46:=显示黄金线=1 AND X_44>=X_45 AND X_45=REF(X_45,1);
X_47:=IF(X_45<X_41,X_41,X_45);
黄金虚线:IF(X_46,X_47,DRAWNULL),POINTDOT,COLORYELLOW;
STICKLINE(显示黄金线=1 AND 基柱 OR X_46,X_47,X_47,17,(-1)),COLORYELLOW;
黄金实线:REF(LLV(X_18,3),X_40),NODRAW,COLORMAGENTA;
STICKLINE(显示黄金线=1 AND 基柱,黄金实线,黄金实线,15,1),COLORBROWN;
X_48:=黄金实线>=X_41;
X_49:=X_44>=X_41;
X_50:=回踩误差千分之*CLOSE/1000;
X_51:=IF(X_50<0.01,0.01,X_50);
X_52:=ABS(X_43-X_41)<=X_51;
X_53:=ABS(X_43-基柱O)<=X_51;
X_54:=ABS(X_43-黄金虚线)<=X_51;
X_55:=ABS(X_43-黄金实线)<=X_51;
X_56:=ABS(X_44-X_41)<=X_51;
X_57:=ABS(X_44-基柱O)<=X_51;
X_58:=ABS(X_44-黄金虚线)<=X_51;
X_59:=ABS(X_44-黄金实线)<=X_51;
X_60:=IF(回踩类型=1 OR 回踩类型=0,X_52 OR X_56,0);
X_61:=IF(回踩类型=2 OR 回踩类型=0,X_53 OR X_57,0);
X_62:=IF(回踩类型=3 OR 回踩类型=0,X_54 OR X_58,0);
X_63:=IF(回踩类型=4 OR 回踩类型=0,X_55 OR X_59,0);
X_64:=X_60 OR X_61 OR X_62 OR X_63 AND X_48 AND X_49;
X_65:=LOW=X_43 OR X_18=X_44;
X_66:=BARSLAST(X_65);
X_67:=VOL<REF(VOL,1) AND 1;
X_68:=REF(CLOSE<OPEN,1) AND CLOSE>OPEN AND CLOSE>REF(MAX(CLOSE,OPEN),1);
X_69:=X_64 AND X_68 AND X_40>=1 AND X_66<=2;
X_70:=COUNT(X_69,1);
DRAWICON(X_70,LOW*0.98,1);

黄金线阳盖阴主图指标 源码 通达信


好股票软件下载网(www.goodgupiao.com)提醒您:股市有风险,投资需谨慎。
黄金线阳盖阴主图指标 源码 通达信下载地址
相关说明
  • 好股票软件下载网欢迎用户将网页内容和下载地址转发到博客、微博、论坛等。
  • 发布的公式指标绝大部分是来源于各大论坛,谢谢各位老师的原创指标。
  • 判断公式指标好坏,请用户参考用户评论或者软件好评度
  • alg格式股票公式,仅仅可以用飞狐交易师股票软件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
  • exp格式股票公式,仅可以用大智慧经典版股票软件引入使用;
  • tnctni格式股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
  • tne格式公式,仅可以用通达信公式编辑器5.0版导入,高版本兼容低版本;
  • hxf格式股票公式,仅可以用同花顺股票软件引入使用。
  • 如果引入公式的时候,发现公式名称栏空白,调整电脑时间到1997年,能出现公式名称并正常显示,可能是公式使用期限已过。
  • 如果您发现下载链接错误,请点击报告错误谢谢!